Error running gyre on OS X 10

Bug/problem reports for any of the GYRE executables (gyre_ad, gyre_nad, etc)
Post Reply
Ippocratis Saltas
Posts: 8
Joined: Mon May 21, 2018 9:09 am

Error running gyre on OS X 10

Post by Ippocratis Saltas » Mon May 21, 2018 9:31 am

Hello,

I am trying to run GYRE on OS X 10 -- I have installed the SDK package, compiled and tested the code, all was succesful.

Setting up an inlist file according to the example from the Wiki, I get the error message below after running "../bin/gyre gyre.in".

Any help would be much appreciated, thanks!

-------------
OpenMP Threads : 4
Input filename : gyre.in

At line 160 of file gyre.f90
Fortran runtime error: Cannot open file 'gyre.in': No such file or directory

Error termination. Backtrace:
#0 0x111343aec
#1 0x111343cd5
#2 0x111346c49
#3 0x1114234af
#4 0x1114237fc
#5 0x10fe6c3cd
#6 0x10ffba538
-------------

User avatar
rhtownsend
Site Admin
Posts: 284
Joined: Sun Mar 31, 2013 4:22 pm

Re: Error running gyre on OS X 10

Post by rhtownsend » Mon May 21, 2018 9:37 am

Ippocratis Saltas wrote:
Mon May 21, 2018 9:31 am
Hello,

I am trying to run GYRE on OS X 10 -- I have installed the SDK package, compiled and tested the code, all was succesful.

Setting up an inlist file according to the example from the Wiki, I get the error message below after running "../bin/gyre gyre.in".

Any help would be much appreciated, thanks!

-------------
OpenMP Threads : 4
Input filename : gyre.in

At line 160 of file gyre.f90
Fortran runtime error: Cannot open file 'gyre.in': No such file or directory

Error termination. Backtrace:
#0 0x111343aec
#1 0x111343cd5
#2 0x111346c49
#3 0x1114234af
#4 0x1114237fc
#5 0x10fe6c3cd
#6 0x10ffba538
-------------
Hi Ippocratis --

It looks like the 'gyre.in' input file is missing -- did you create it?

cheers,

Rich

Ippocratis Saltas
Posts: 8
Joined: Mon May 21, 2018 9:09 am

Re: Error running gyre on OS X 10

Post by Ippocratis Saltas » Mon May 21, 2018 10:10 am

Hello Rich,

Thanks for your prompt response. Yes, I did create it, after copy-pasting the template on the Wiki's tutorial.

Thanks!
Ippocratis

User avatar
rhtownsend
Site Admin
Posts: 284
Joined: Sun Mar 31, 2013 4:22 pm

Re: Error running gyre on OS X 10

Post by rhtownsend » Mon May 21, 2018 10:12 am

Ippocratis Saltas wrote:
Mon May 21, 2018 10:10 am
Hello Rich,

Thanks for your prompt response. Yes, I did create it, after copy-pasting the template on the Wiki's tutorial.

Thanks!
Ippocratis
Hmm, that's puzzling. Can you post the output from 'ls -l' in the directory where you are trying to run GYRE?

cheers,

Rich

Ippocratis Saltas
Posts: 8
Joined: Mon May 21, 2018 9:09 am

Re: Error running gyre on OS X 10

Post by Ippocratis Saltas » Mon May 21, 2018 10:17 am

Sure, please find them below -- A screenshot of ls-l on the entire gyre folder and another within the "work" folder.

Cheers,Ippocratis
Attachments
Screen Shot 2018-05-21 at 17.15.01.png
Screen Shot 2018-05-21 at 17.15.01.png (142.12 KiB) Viewed 246 times

User avatar
rhtownsend
Site Admin
Posts: 284
Joined: Sun Mar 31, 2013 4:22 pm

Re: Error running gyre on OS X 10

Post by rhtownsend » Mon May 21, 2018 10:24 am

Ippocratis Saltas wrote:
Mon May 21, 2018 10:17 am
Sure, please find them below -- A screenshot of ls-l on the entire gyre folder and another within the "work" folder.

Cheers,Ippocratis
Hi Ippocratis --

Please post the screen output by cutting and pasting from the terminal -- not as images.

cheers,

Rich

Ippocratis Saltas
Posts: 8
Joined: Mon May 21, 2018 9:09 am

Re: Error running gyre on OS X 10

Post by Ippocratis Saltas » Mon May 21, 2018 10:27 am

Of course, sorry for that -- Please find them below.
cheers, Ippocratis

* Gyre folder:

total 88
-rw-r--r--@ 1 ippocratissaltas staff 35147 Apr 20 14:07 COPYING
-rw-r--r--@ 1 ippocratissaltas staff 437 Apr 20 14:07 Makefile
-rw-r--r--@ 1 ippocratissaltas staff 376 Apr 20 14:07 README
drwxr-xr-x@ 5 ippocratissaltas staff 160 May 21 16:04 bin
drwxr-xr-x@ 3 ippocratissaltas staff 96 Apr 20 14:09 data
drwxr-xr-x@ 17 ippocratissaltas staff 544 Apr 20 14:09 doc
drwxr-xr-x@ 6 ippocratissaltas staff 192 May 21 15:40 models
drwxr-xr-x@ 6 ippocratissaltas staff 192 Apr 20 14:09 python
drwxr-xr-x@ 27 ippocratissaltas staff 864 Apr 20 14:09 src
drwxr-xr-x@ 9 ippocratissaltas staff 288 Apr 20 14:09 test
drwxr-xr-x 4 ippocratissaltas staff 128 May 21 17:13 work

*Work folder:

total 1760
-rw-r--r--@ 1 ippocratissaltas staff 2035 May 21 17:13 gyre.in.rtf
-rw-r--r--@ 1 ippocratissaltas staff 894397 May 21 15:42 spb.mesa

User avatar
rhtownsend
Site Admin
Posts: 284
Joined: Sun Mar 31, 2013 4:22 pm

Re: Error running gyre on OS X 10

Post by rhtownsend » Mon May 21, 2018 10:29 am

Ippocratis Saltas wrote:
Mon May 21, 2018 10:27 am
Of course, sorry for that -- Please find them below.
cheers, Ippocratis

* Gyre folder:

total 88
-rw-r--r--@ 1 ippocratissaltas staff 35147 Apr 20 14:07 COPYING
-rw-r--r--@ 1 ippocratissaltas staff 437 Apr 20 14:07 Makefile
-rw-r--r--@ 1 ippocratissaltas staff 376 Apr 20 14:07 README
drwxr-xr-x@ 5 ippocratissaltas staff 160 May 21 16:04 bin
drwxr-xr-x@ 3 ippocratissaltas staff 96 Apr 20 14:09 data
drwxr-xr-x@ 17 ippocratissaltas staff 544 Apr 20 14:09 doc
drwxr-xr-x@ 6 ippocratissaltas staff 192 May 21 15:40 models
drwxr-xr-x@ 6 ippocratissaltas staff 192 Apr 20 14:09 python
drwxr-xr-x@ 27 ippocratissaltas staff 864 Apr 20 14:09 src
drwxr-xr-x@ 9 ippocratissaltas staff 288 Apr 20 14:09 test
drwxr-xr-x 4 ippocratissaltas staff 128 May 21 17:13 work

*Work folder:

total 1760
-rw-r--r--@ 1 ippocratissaltas staff 2035 May 21 17:13 gyre.in.rtf
-rw-r--r--@ 1 ippocratissaltas staff 894397 May 21 15:42 spb.mesa
I see your problem -- your gyre.in file has been saved as a Rich Text Format (.rtf) file. You should re-create it as a raw text file, with no extension.

cheers,

Rich

Ippocratis Saltas
Posts: 8
Joined: Mon May 21, 2018 9:09 am

Re: Error running gyre on OS X 10

Post by Ippocratis Saltas » Tue May 22, 2018 5:22 am

Thanks, Rich! That solved the problem.
Cheers, I.

Post Reply